Instalar festival en Debian.

Para tener instalado festival en nuestro equipo y poder usarlo con el lector de pantalla orca, tenemos que hacer lo siguiente:

  1. Abrimos una terminal o consola en aplicaciones (alternar + F1) > accesorio > terminal
  2. Ya con el terminal abierto entraremos como superusuario, escribiremos:

# su y luego la contraseña

  1. Ahora instalaremos festival escribiendo en la consola:

# aptitude install festival

esto nos instalara en el equipo dicha aplicación.

  1. Para instalar las voces en español, haremos lo siguiente:
    1. Instalar primero la voz en español que esta en los repositorios, así que escribiremos en la consola:

# aptitude install festvox-ellpc11k

    1. Descargar la voz femenina y masculina desde aquí:http://forja.guadalinex.org/frs/?group_id=21
    2. Instalamos las voces de la siguiente forma, escribiendo en la consola:

# dpkg -i festvox-palpc16k_1.0-1_all.deb

# dpkg -i festvox-sflpc16k_1.0-1_all.deb

  1. Ya tendremos nuestro festival para usarlo con el lector de pantalla orca, solo queda ir a las preferencias y seleccionar el sintetizador de voz con la voz que queramos utilizar.

Nota: Para verificar si el sintetizador de voz “festival” reproduce audio se coloca en la consola lo siguiente:

$ echo “hello world” | festival –tts

si produce un error:

Linux: can’t open /dev/dsp

se debe colocar en el home del usuario lo siguiente.

printf “;use ALSA\n(Parameter.set ‘Audio_Method ‘Audio_Command)\n(Parameter.set ‘Audio_Command \”\

aplay -q -c 1 -t raw -f s16 -r \$SR \$FILE\”)\n” > .festivalrc

se reinicia el computador y ya debería funcionar correctamente festival con el lector de pantalla.

Hasta la próxima y deseándoles muchos éxitos.

Anuncios

7 pensamientos en “Instalar festival en Debian.

  1. Lo intenté…pero tengo un serio problema en debian, el sintetizador de voz Festival funciona con un eco muy desagradable por lo que no puedo utilizarlo con orca.
    Esto me ocurre tanto con las voces de hispavox como con la voz de español predeterminada.
    Curiosamente esto no me pasaba cuando trabajaba con ubuntu 10.4 ¿a qué puede ser debido?
    Por cierto ¿sabes de algún sinteitizador de voz que funcione con con Orca y Debian y tenga voces que suenen más “humanas”? algo que no suene a voz de lata…
    Probé en su día con voxin en mi anterior ubuntu pero tube una experiencia desagradable ya que mi equipo se quedó “mudo” inesperadamente y aunque finalmente volvió a funcionar lo cierto es que el sonido estuvo dándome muchos problemas por lo que finalmente desinstalé voxin ¿conoces alguna otra alternativa o has probado con voxin en Debian?

      • Bueno yo estoy usando la versión 2.1 de festival y tengo los mismos problemas que tu, estoy preguntando en otra lista haber si saben como resolver estas dificultades, cualquier solución, lo publico….saludos.

  2. yo las estoy probando en orca 3.1.2, los problemas que tengo (además del eco) son:
    – con la calculadora de gnome (gcalctool) orca (con festival) no lee correctamente el signo menos o directamente no lo lee, lo que es un problema cuando trabajas con operaciones con números negativos.
    – si abro daisy para reproducir un libro, este se reproduce perfectamente pero festival enmudece por completo y tengo que reiniciar orca para que el sistema vuelva a ser accesible
    – probando con la versión 9 de acrobat reader, al reproducir un pdf este se escucha con las opciones de accesibilidad del lector de pdf (utiliza festival) pero orca se cuelga por completo y otra vez el sistema deja de ser accesible

    Pensé en probar la última versión de Festival (2.1 en este momento) pero no tiene paquete deb, tendría que compilarlo y yo en eso me pierdo… ¿alguna sugerencia?

  3. Muchas gracias por la información, es muy difícil encontrar a gente con debian, orca, festival 2.1 y que además conteste en los foros.
    De verdad, muchas gracias.
    …y si no es abuso ¿probaste con las voces de voxin? yo había hecho una prueba decepcionante en ubuntu 10.4 y casi no me atrevo a probar en debian.

    • bueno la verdad, lo intente la otra vez sin muchos resultados, aunque tenía una versión muy vieja y creo que no daba soporte en debian, ya que daba problemas en la instalción …. así que no te puedo dar mucha información.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s